Tính tiền điện

Thảo luận trong 'Ứng dụng Excel' bắt đầu bởi nedved, 26 Tháng bảy 2005.

4,008 lượt xem

  1. nedved

    nedved Thành viên hoạt động

    Bài viết:
    687
    Đã được thích:
    2
    Nơi ở:
    Xa xa nương dâu
    Thân chào các chuyên gia về excel,

    Mình có làm công thức tính tiền điện nhưng toàn báo lỗi [HASHTAG]#NAME[/HASHTAG]?

    Bạn nào sửa lại giúp mình với, rất cảm ơn

    Bạn làm ơn chỉ cho mình tại sao bị sai nhé, vì cùng công thức đó sang máy khác lại được. Mình đang cần rất gấp

    Many thanks
     

    Các file đính kèm:

    #1
  2. adam_tran

    adam_tran Steel Partner

    Bài viết:
    1,373
    Đã được thích:
    32
    Nơi ở:
    Goooogle
    - Lỗi [HASHTAG]#Name[/HASHTAG] vì bạn đã sử dụng dấu (.) thay vì phải dấu (,). Bạn kiểm tra lại Regional Setting ngoài Control Panel, chỗ list seprator.
    - Về cách làm và công thức, bạn đã làm đúng, tuy vậy địa chỉ tham chiếu của các hàm MATCH bị sai, tớ đã sửa lại, bạn xem file đính kèm.
    - Bạn chưa để bảng giá cho chỉ số vượt định mức, tớ tạm tính như giá thường.

    Hôm nay xin phép các tiền bối múa rìu một chút, mong được chỉ giáo thêm.
     
    Last edited: 26 Tháng bảy 2005
    #2
  3. nedved

    nedved Thành viên hoạt động

    Bài viết:
    687
    Đã được thích:
    2
    Nơi ở:
    Xa xa nương dâu
    Rất cảm ơn bạn adam tran,

    Mình đã xem lại regional setting, tuy nhiên vấn đề là không hiểu sao, khi tôi bấm F2 và Enter một cái thì nó lại báo là [HASHTAG]#NAME[/HASHTAG]? (theo công thức trong file của bạn)

    Vậy thì có phải là Excel của tôi có vấn đề gì không?

    Mong các bạn chỉ giùm

    Cảm ơn các bạn
     
    #3
  4. ForestC

    ForestC Thành viên hoạt động

    Bài viết:
    377
    Đã được thích:
    1
    Nơi ở:
    E'rywhere
    Vấn đề mà nedved gặp phải bạn Adam tran trả lời hoàn toàn chính xác: Nedved vừa sai khi dùng tới 3 dấu . trong khi phải dùng dấu ; Thêm nữa, nếu Nedved sửa 3 dấu chấm này thành 3 dấu chấm phẩy thì công thức vẫn cho kết quả không đúng (tất nhiên là không còn [HASHTAG]#name[/HASHTAG] ) . Lý do bởi vì tham chiếu cho 2 hàm match của Nedved chưa chính xác. Tham chiếu của hàm match phải tương đồng với tham chiếu của hàm index. Gửi Nedved toàn bộ lời giải cho bài toán này qua file của tớ. Thêm nữa máy của Nedved ko có vấn đề gì về Regional Setting cả. Nếu Nedved cần trao đổi thêm về các đề tin CPA, thì cứ contact tớ nhé.
     

    Các file đính kèm:

    #4
  5. nedved

    nedved Thành viên hoạt động

    Bài viết:
    687
    Đã được thích:
    2
    Nơi ở:
    Xa xa nương dâu
    Thanks Maika,

    Chỉ có điều là tớ thử lại như thế này mà vẫn bị lỗi.

    Lấy file của Maika. chọn ô có công thức. Bấm F2, sau đó bấm Enter => [HASHTAG]#NAME[/HASHTAG]?

    Lập lại công thức khác vẫn bị như vậy. Không hiểu là lỗi tại sao
     

    Các file đính kèm:

    #5
  6. adam_tran

    adam_tran Steel Partner

    Bài viết:
    1,373
    Đã được thích:
    32
    Nơi ở:
    Goooogle
    - Bạn kiểm tra lai Regional Setting, có thể ký tự định dạng dấu ngăn cách (list seprator symbol) của bạn bị trùng với ký tự thập phân (decimal symbol) hoặc digit group symbol v...v. Bạn reset - restore lại system theo US standard hoặc Vietnamese. Tớ nghỉ lý do cho trường hợp này là 20%.
    - Kiểm tra lại Auto Correct: Bạn kiểm tra lại công thức sau khi nhấn F2-Enter, xem những chỗ nào ký tự ";" (hoặc "," tùy định dạng List Seperator) bị thay thế bằng dấu "." . Chính dấu "." này làm cho công thức bạn bị lỗi. Khi để nguyên công thức thì không sao, bạn nhấn F2-Enter thì Auto Correct sẽ thay một cụm từ nào đó có dấu ";" thành dấu "." và kết quả là [HASHTAG]#Name[/HASHTAG]. Bạn kiểm tra lại Auto Correct xem, nhớ Auto Correct có khá nhiều Options, tớ không chắc Options nào gây lỗi này. Chúc bạn thành công.
     
    #6
  7. handung107

    handung107 Thành viên thân thiết

    Bài viết:
    576
    Đã được thích:
    13
    Nơi ở:
    VN
    Tôi đã xem thử File của Nedved, và chỉ làm một động tác duy nhất là kéo rê công thức từ ô nào có kết quả lên các ô có chữ [HASHTAG]#NAME[/HASHTAG], rồi nhấn F2 và Enter, kết quả như ý. Đúng như các bạn nói, Nedved đã để cho công thức lẫn lộn các dấu phẩy và chấm. Trong các công thức, không phải chỉ toàn dấu phẩy, cũng không toàn dấu chấm, nên vào Regional Setting cũng không ăn thua gì. Bạn hãy xem lại, nếu theo mặc định của Excel sẽ là dấu phẩy hay chấm phẩy. Nếu bạn Setting là dấu chấm, thì toàn bộ các vị trí trong công thức của bạn phải là dấu chấm. Bạn chỉ cần sửa lại là xong
     
    #7
  8. nedved

    nedved Thành viên hoạt động

    Bài viết:
    687
    Đã được thích:
    2
    Nơi ở:
    Xa xa nương dâu
    Cảm ơn mọi người rất nhiều.

    Mình đã xem lại file. Sửa lại regional setting nhưng nếu để định dạng English thì dùng được, chuyển sang dạng (.,) kiểm việt nam thì lại báo [HASHTAG]#NAME[/HASHTAG]?

    Nhân tiện các bạn cho mình hỏi luôn, là làm thế nào để tổng hợp tiền điện theo từng loại hộ (như file trên). Mình đã thử lại theo công thức của các bạn nhưng không được: =SUM(IF(LEFT($C$5:$C$9,2)=H21,$I$5:$I$9,0)).

    Khi mình bấm F2 thì thấy công thức nằm trong 2 dấu { }, nghĩa là như thế nào. Các bạn có thể chỉ dẫn cách làm giúp mình được không.

    Rất cảm ơn
     
    #8
  9. WhoamI

    WhoamI Thành viên thân thiết

    Bài viết:
    534
    Đã được thích:
    0
    Nơi ở:
    Cố lên, cứ đi rồi sẽ tới!
    Đây là công thức mảng bác phải ấn đồng thời tổ hợp phím : Ctrl + Shift + Enter
    Ngoài ra có thể chuyển công thức trên thành = Sumproduct((LEFT($C$5:$C$9,2)=H21)*($I$5:$I$9)) để đỡ tốn nhớ và đỡ phải ấn Ctrl + Shift + Enter
     
    #9
  10. adam_tran

    adam_tran Steel Partner

    Bài viết:
    1,373
    Đã được thích:
    32
    Nơi ở:
    Goooogle
    Regional Setting

    Có một số bản Windows không support chuẩn Việt Nam trong phần Location, do đó bạn phải tự thay đổi các chuẩn số, date, time... Trong Win 98, Me, thậm chí XP nếu bạn chọn những symbol trùng nhau cho các option, một số công thức thậm chế câu lệnh lập trình sẽ báo lỗi.
    Nếu bạn muốn chuyển sang chuẩn Việt Nam, phần decimal symbol là "," , digit group symbol là "." thì list separator phải là ";". Nếu bạn cứ dùng "," thì sẽ gặp lỗi như tớ nói ở trên.
     
    #10
  11. nedved

    nedved Thành viên hoạt động

    Bài viết:
    687
    Đã được thích:
    2
    Nơi ở:
    Xa xa nương dâu
    Cảm ơn tất cả các bạn, nếu dùng chuẩn Việt Nam thì tôi phải sửa trực tiếp trên Excel và dùng ";" khi lập các functions.

    Cảm ơn các bạn
     
    #11
  12. ForestC

    ForestC Thành viên hoạt động

    Bài viết:
    377
    Đã được thích:
    1
    Nơi ở:
    E'rywhere
    hihi, Paven Neđveđ bị cãi lỗi đó ở máy nào vậy, máy bàn hay laptop? Nếu là laptop mang qua đây tớ sửa cho.
     
    #12

Chia sẻ trang này